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Introduction

Introduction

Overview
Solids Modelling allows us to use triangulation to create three-dimensional models based on Digital
Terrain Models (DTMs) and String files. This tutorial introduces the theory behind the solids mod-
elling process and provides detailed examples using the solids modelling functions in Surpac.  By
working through this tutorial, you will gain skills in the construction, use of and modification of sol-
ids models.

Requirements
This tutorial assumes that you have a basic knowledge of Surpac. We recommend that you under-
stand the procedures and concepts in the Introduction to Surpac manual. The DTM Surfaces tuto-
rial may also be helpful in understanding some of the concepts in this tutorial.

You will also need to have:

● Surpac installed on your computer, and
● The data set accompanying this tutorial.

Workflow

Note: This workflow demonstrates the steps in this tutorial. There are other ways to achieve a
result.
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Solids Concepts

Solids Concepts

What is a Solid model?
A Solid model is a three-dimensional triangulation of data. For example, a solid object may be
formed by wrapping a DTM around strings representing sections through the solids.

Solid models are based on the same principles as Digital Terrain Models (DTMs). Solid models use
triangles to link polygonal shapes together to define a solid object or a void.

The resulting shapes may be used for:

● visualisation.
● volume calculations.
● extraction of slices in any orientation.
● intersection with data from the geological database module.

A DTM is used to define a surface. Creating a DTM is automatic. Triangles are formed by connecting
groups of three data points together by taking their spatial location in the X - Y plane into account.

The drawback of this type of model is that it cannot model a structure that may have foldbacks or
overhangs, for example:

● geological structure.
● stopes.
● underground mine workings, for example: declines, development drives and draw points.

A Solid model is created by forming a set of triangles from the points contained in the string. These
triangles may overlap when viewed in plan, but do not overlap or intersect when the third dimen-
sion is considered. The triangles in a solid model may completely enclose a structure.

Creation of Solid models can be more interactive than the creation of DTMs, although there are
many tools in Surpac that can automate the process.

The following diagram shows an example of a Solid model (design decline and ore body).

Terminology
A Solid model is made up of a set of non-overlapping triangles. These triangles form objects that
may have a numeric identifier between 1 and 32000. Objects represent discrete features in a solid
model. For example, in the above diagram, the decline and the ore bodies have different object
numbers since they represent different features.

However, features such as ore bodies can consist of discrete pods, and you may want to give
these pods the same object number to indicate that they are from the same structure. In this
case, each discrete pod must have a different trisolation number. A trisolation is a discrete part of
an object and may be any positive integer.

Object and Trisolation numbers give reference to all the objects contained in a Solid model.

An object trisolation may be open or closed. A trisolation is open if there is a gap in the set of tri-
angles that make up the trisolation. An object may contain both open and closed trisolations.
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Solids Concepts

The reason for treating objects as open or closed are:

● a closed object can have its volume determined directly by summing the volumes of each of
the triangles to an arbitrary datum plane.

● a closed object always produces closed strings when sliced by a plane.
● a closed object could be used as a constraint in the Block Modelling module.
● an open object cannot provide the same capabilities; when sliced by a plane the strings it

produces may be open or closed or both.

Solids Files
Solid models are stored in the same way that DTMs are stored, in two ASCII text files, with .str and
.dtm extensions.
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Set Up For This Tutorial Task: Set the Work Directory (Windows XP)

Set Up For This Tutorial

Task: Set the Work Directory (Windows XP)

1. In the Navigator, right-click the solids folder.
2. From the popup menu, select Set as work directory.

The name of the work directory is displayed in the title bar of the Surpac window.
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Set Up For This Tutorial Task: Set the Work Directory (Windows Vista)

Task: Set the Work Directory (Windows Vista)

1. In the Navigator, right-click the solids folder.
2. From the popup menu, select Set as work directory.

The name of the work directory is displayed in the title bar of the Surpac window.
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Preparing Data Task: Combine String Files into one File

Preparing Data

Task: Combine String Files into one File

1. Choose File tools > Combine/Split file options > Combine string files.
2. Enter the information as shown, and then click Apply.

This will combine all sixteen files into one string file called ore1.str.

3. Choose File tools > Change string directions.
4. Enter the information as shown, and then click Apply.

This will ensure that all digitised segments are set to clockwise. This string file is a series of sectional
interpretations, representing a copper ore body.
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Preparing Data Task: Check String File Directions Using String File Summary

Task: Check String File Directions Using String File Summary

1. Choose File tools > String summary.
2. Enter the information as shown, and then click Apply.

3. Enter the information as shown, and then click Apply.

File summary1.not is displayed.

4. Close summary1.not.
5. Click the Reset graphics icon .
6. Open ore1.str.
7. Choose Display > Strings > With string numbers.
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Preparing Data Task: Check String File Directions Using String File Summary

8. Enter the information as shown, and then click Apply.

Ore 1 string is displayed.

Note: The same results could be achieved by opening all the files into one layer and then saving
the layer as ore1.str.

Use this file to do a final check that all strings are closed and clockwise in direction.
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Preparing Data Task: Transform Data from Section View to Plan View

Task: Transform Data from Section View to Plan View

1. Click the Reset graphics icon .
2. Choose File tools > String maths.
3. Enter the information as shown, and then click Apply.

4. Openmod1.str.
The plan view of the segments is displayed.

Task: Check and Remove Foldbacks

1. Click the Reset graphics icon .
2. Openmod1.str.
3. Choose Edit > Layer > Clean.

Note: By using the Layer option, all strings are checked.
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Preparing Data Task: Check and Remove Foldbacks

4. Enter the information as shown, and then click Apply.

A temporary marker (a red circle) appears on one of the segments.

5. Zoom in on the highlighted area to view the foldback.

6. Re-run the Clean function with Action set to remove.
This will automatically remove the foldback.

Note: Any errors highlighted by the Clean Layer function can also be manually edited if pre-
ferred.
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Preparing Data Task: Highlight and Remove Duplicate Points

Task: Highlight and Remove Duplicate Points

1. Click the Reset graphics icon .
2. Openmod1.str.
3. Choose Edit > Layer > Clean.
4. Enter the information as shown, and then click Apply.

Note: Duplicate points are highlighted by a temporary marker (red hash symbol) as shown. 
Surpac will not triangulate points less than 0.05 units apart.

5. Re-run the Clean function with Action set to remove to delete any duplicate points.

Note:To see all of the steps performed in this section, run _01_data_preparation.tcl. You will
need to click Apply on any forms presented.
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Creating a Solid Task: Create a Solid Model

Creating a Solid
The following sections describe the various triangulation methods that can be used to create a
Solid model.

Triangulating Using Between Segments

Task: Create a Solid Model

1. Click the Reset graphics icon .
2. Openmod1.str.
3. Choose Display > Strings > With string numbers.
4. Enter the information as shown, and then click Apply.

5. Choose Solids > Triangulate > Between segments.
6. Enter the information as shown, and then click Apply.

You are prompted to Select a point on the first segment to be triangulated.

7. Click string 1.
You are prompted to Select a point on the next segment to be triangulated.

8. Click string 2.
Continue using the Between segments function up to and including string 5.

9. Press ESC.
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Creating a Solid Task: Create a Solid Model

The part of the solid created using triangulate between segments is displayed.

10. Save mod1.dtm.

Note: You can use the Between segments function indefinitely as long as the selected strings
are still in the same active layer as the first string selected.

Note: To see all of the steps performed in this section, run _02a_create_solid_automatic_tri-
angulation.tcl. You will need to click Apply on any forms presented.
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Creating a Solid Task: Create Control Strings Using the Digitiser

Triangulating Using Control Strings

Task: Create Control Strings Using the Digitiser

1. Click the Reset graphics icon .
2. Openmod2.dtm.
3. Choose Display > Hide everything to erase all strings and objects.
4. Choose Display > Strings > With string numbers.
5. Enter the information as shown, and then click Apply.

Strings 5 to 10 are displayed.

6. Choose Create > Digitise > Start new string.
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Creating a Solid Task: Create Control Strings Using the Digitiser

7. Enter the information as shown, and then click Apply.

8. Choose Create > Digitise > New point by selection.
Each point digitised will snap to an existing point in each polygon.

9. Digitise string 100 as shown between strings 5 and 10.

10. Choose Create > Digitise > Start next string.
11. Choose Create > Digitise > New point by selection and digitise string101.
12. Choose Create > Digitise > Start next string.
13. Choose Create > Digitise > New point by selection and digitise string102.
14. Press ESC.
15. Choose Solids > Triangulate > Using control strings.
16. Click on String 100.

Tip: When selecting each control string graphically, click on the string midway between the
polygons. This will ensure that the control string is correctly selected.

17. Next, click String 101 and then click String 102.
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Creating a Solid Task: Create Control Strings Using the Digitiser

18. Press ESC.
19. Enter the information as shown, and then click Apply.

The part of the solid which uses control strings is displayed.

20. Choose File > Save as > string/DTM to save this part of the model asmod2.dtm.

21. Click Yes.

Note: To see all of the steps performed in this section, run _02b_create_solid_control_
strings.tcl. You will need to click Apply on any forms presented.
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Creating a Solid Task: Create a Solid by Specifying a Range of Strings

Triangulating Using Many Segments

Task: Create a Solid by Specifying a Range of Strings

1. Click the Reset graphics icon .
2. Openmod3.dtm.
3. Choose Display > Hide everything to erase all strings and objects.
4. Choose Display > Strings > With string numbers.
5. Enter the information as shown, and then click Apply.

Note: The range definition form could be applied with a blank string range to triangulate all
strings in the current graphic layer.

6. Choose Solids >Triangulate > Many segments.
7. Enter the information as shown, and then click Apply.

8. Enter the information as shown, and then click Apply.
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Creating a Solid Task: Perform Bifurcation - One Segment to Many Segments

9. Enter the information as shown, and then click Apply.

Selected segment image is displayed.

10. Save asmod3.dtm.

11. Click Yes.

If you want to run manually through the material again, you will need to copy original_mod3.dtm
tomod3.dtm.

Note: To see all of the steps performed in this section, run _02c_create_solid_triangulate_
many_segments.tcl. You will need to click Apply on any forms presented.

Triangulating Using Bifurcation Techniques

Task: Perform Bifurcation - One Segment to Many Segments

1. Click the Reset graphics icon .
2. Open bifurc1.str.

Put it in a suitable view so that you can see all three shapes.

3. Choose Display > Point > Markers to display all points as markers.
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Creating a Solid Task: Perform Bifurcation - One Segment to Many Segments

The Parent and Child segments with Markers are displayed:

4. Choose Solids > Triangulate > One segment to many segments.
5. Enter the information as shown, and then click Apply

6. Enter the information as shown, and then click Apply.

You are prompted to select the first break point on the parent segment for the first child.

7. Click the parent segment.
Here you are being asked to select where you are going to perform the bifurcation,

You are prompted to select the second break point on the parent segment for the first child.

8. Click the opposite side of the parent segment.
The bifurcation example is displayed.
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Creating a Solid Task: Perform One Segment to Two Segments (Bifurcation Union)

You are asked to select the portion of the parent segment to join to the first child. This means
which side of the parent will you join up with which child.

9. Click the left side of the parent segment.
10. Enter the information as shown, and then click Apply.

11. Click the left child.
You are asked whether the next child is a segment or a point

12. Click Apply on this form and then click the right child.
The bifurcation example is displayed.

Note: This is just one way of performing a bifurcation. The benefits are the relative simplicity
and the ability to split the parent string to more than two components.

Task: Perform One Segment to Two Segments (Bifurcation Union)

1. Click the Reset graphics icon .
2. Open bifurc1.str.
3. Choose View > Data view options > View by bearing & dip.
4. Enter the information as shown, and then click Apply.

5. Choose Solids > Triangulate > One segment to two segments.
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Creating a Solid Task: Perform Bifurcation Union – Split Parent

6. Enter the information as shown, and then click Apply.

7. Enter the information as shown, and then click Apply.

You are prompted to select the parent segment.

8. Click the parent segment.
You are then prompted to choose whether the first child is a (S)egment or a (P)oint.

9. Click Apply, and then click the left child.

You are then prompted to choose whether the second child is a (S)egment or (P)oint.

10. Click Apply, and then click the right child.

The bifurcation example is displayed.

Task: Perform Bifurcation Union – Split Parent

1. Click the Reset graphics icon .
2. Open bifurc1.str.
3. Put it in a suitable view so that you can see all three shapes.
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Creating a Solid Task: Perform Bifurcation Union – Split Parent

4. Choose Display > Point > Markers to display all points as markers.
The bifurcation example is displayed.

5. Choose Solids > Triangulate > One segment to two segments.
6. Enter the information as shown, and then click Apply.

7. Enter the information as shown, and then click Apply.

The position of the line of bifurcation is controlled by splitting the parent segment in different
ways.

Note: The two breaklines defined must always overlay as shown.
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Creating a Solid Task: Perform Bifurcation Union – Split Parent

Note: The first series of prompts will define a portion of the parent segment to be assigned
to the first child.

8. Click the first break point on the parent segment for the first child (ie. point 1 as shown)
9. Click the second break point on the parent segment for the first child (ie. point 2 as shown)
10. Click the parent segment on the left side of the defined breakline.
11. Click Apply and then click child 1.

Note: The next series of prompts will define a portion of the parent segment to be
assigned to the second child.

12. Click the first break point on the parent segment for the second child(point 3 as shown).
13. Click the second break point on the parent segment for the second child(point 4 as shown).
14. Click the parent segment on the right side of the defined breakline.
15. Click Apply and then click child 2.
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Creating a Solid Task: Use One Segment to Two Segments to Model a Bifurcation.

The bifurcation example is displayed.

Note: To see all of the steps performed in this section, run _03a_bifurcation.tcl. You will need
to click Apply on any forms presented.

Task: Use One Segment to Two Segments to Model a Bifurcation.

1. Click the Reset graphics icon .
2. Openmod4.dtm.
3. Choose Display > Hide everything.
4. Choose Display > Strings > With string numbers.
5. Enter the information as shown, and then click Apply.

Note: String 14will be the parent segment and the two segments of string 15will be the
child segments.

6. Choose Solids > Triangulate > One segment to two segments.
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Creating a Solid Task: Use One Segment to Two Segments to Model a Bifurcation.

7. Enter the information as shown, and then click Apply.

8. Enter the information as shown, and then click Apply.

You are prompted to select the parent segment.

9. Click string 14.
You are then prompted to state whether the first child is a (S)egment or a (P)oint.

10. Enter the information as shown, and then click Apply.

11. Click the left child segment of string 15.
A prompt will appear asking whether the second child is a (S)egment or (P)oint.

12. Enter the information as shown, and then click Apply.

13. Click the right child segment of string 15.
14. Choose Display > All layers.
15. Click the Zoom all icon .
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Creating a Solid Task: Perform Bifurcation Using the Triangulate Shape Tool

The following image is displayed.

16. Save asmod4.dtm.

Note: To see all of the steps performed in this section, run _03b_bifurcation_on_model.tcl. You
will need to click Apply on any forms presented.

Task: Perform Bifurcation Using the Triangulate Shape Tool

1. Start the triangulation.
2. Open bifurc4.str.
3. Zoom out.

4.
Choose the Triangulate Shape tool by clicking the icon.

5. Click the start point as shown.

Notice that the point is highlighted as you hover over it, or if you click the point.
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Creating a Solid Task: Perform Bifurcation Using the Triangulate Shape Tool

6. Select the line of bifurcation as shown, clicking the points indicated with green arrows.

Hint: When selecting the points in a segment, Surpac chooses the shortest path between two
points.  This sometimes gives unwanted results by either skipping intermediate points or flip-
ping to the opposite side of the segment.  This is easily fixed by clicking on the intermediate
points, which anchors the point by forcing Surpac to select it.

7. Continue selecting the shape by following the left child node as shown and returning to the
start point.

8. Notice that once the shape is joined up by clicking at the start point, that part of the model is
triangulated as shown.

You have now triangulated the right side of the left child and next you will triangulate the left
side of the left child.

9. Select the points as shown, finishing at the point where you started.

You have now finished the triangulation for the left child
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Creating a Solid Task: Perform Bifurcation Using the Triangulate Shape Tool

10. Select the points as shown, finishing at the point where you started.

You have now triangulated the left side of the right child.

11. Select the points as shown, finishing at the point where you started.

12. You have now finished triangulating the bifurcation using the Triangulate Shape tool.
The bifurcation example is displayed.

Next you will use data-centric mode to triangulate inside the parent and child segments to
close the solid.

13. Click the Select Mode tool and select Segment/Trisolation mode as shown.

14. Click the parent segment to select it, and then right click to display a popup menu.

Page 32 of 110



Creating a Solid Task: Perform Bifurcation Using the Triangulate Shape Tool

15. Choose Triangulate.

Notice that the parent segment has become closed.

16. Click the left child segment to select it, and then right click to display a popup menu.
17. Choose Triangulate.
18. Click the right child segment to select it, and then right click to display a popup menu.
19. Choose Triangulate.

The closed solid is displayed.

20. Save the solid model as bifurc4finished.dtm.
21. Choose Solids > Validation > Validate object.
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Creating a Solid Task: Perform Bifurcation Using the Triangulate Shape Tool

22. Enter the information as shown, and then click Apply.

23. Open the file valid1.not in a text editor.
The Solids Modelling Validation report is displayed.

You can see that from the report that the solid is closed and validated.
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Creating a Solid Task: Create Points to Triangulate Using the Digitiser

Triangulating Using Segment to a Point
Segment to a point is a useful function for creating the ends of your ore body. In the following
tasks you will learn about:

● Creating points to triangulate using the digitiser.

● Creating a solid using Segment to a point.

Task: Create Points to Triangulate Using the Digitiser

1. Click the Reset graphics icon .
2. Openmod5.dtm.
3. Choose Display > Hide everything to erase all strings and objects.
4. Choose Display > Strings > With string numbers.
5. Enter the information as shown, and then click Apply.

6. Click the icon to put the data in section view.
The strings are displayed.

7. Move the cursor to the centre of string 1 as shown.

Notice that the elevation (z) of the centre point of string 1 is at approximately 990m.
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Creating a Solid Task: Create Points to Triangulate Using the Digitiser

8. Move the cursor to the centre of string 16 as shown.

Notice that the elevation (z) of the centre point for string 16 is at approximately 1035m.

You will now digitise string 1001 as shown to use as end points for the model.

9. Click the icon to zoom to the extents of the data and return the data to plan view.
10. Zoom out to create space for the end points.
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Creating a Solid Task: Create Points to Triangulate Using the Digitiser

11. Choose Create> Digitise > Properties.
12. Enter the information as shown, and then click Apply.

You will now use the digitiser to create the end points for triangulation.

13. Choose Create > Digitise options > Enter attributes for each point.
14. Choose Create > Digitise > New point at mouse location.
15. Click the southern most point.
16. Enter the information as shown, and then click Apply.

17. Click the northern most point.
18. Enter the information as shown, and then click Apply.

19. Click the final point on string 1001.
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Creating a Solid Task: Create Points to Triangulate Using the Digitiser

20. Enter the information as shown, and then click Apply.

21. Press ESC to finish digitising.
22. Click the icon to view the data in long section view.
23. Choose Display > Point > Attributes.
24. Enter the information as shown, and then click Apply.

The data is displayed as shown.

25. Choose Display > Strings > With string numbers.
Enter the information as shown, and then click Apply.
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Creating a Solid Task: Create a Solid Using Segment to a Point

26. Click the icon from the toolbar to zoom to the extents of the data and return the data to
plan view.
The strings are displayed as shown.

27. Save mod5.dtm.

Task: Create a Solid Using Segment to a Point

1. Click the Reset graphics icon .
2. Openmod5.dtm.
3. Choose Display > Hide everything to erase all strings and objects.
4. Choose Display > Strings > With string numbers.
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Creating a Solid Task: Create a Solid Using Segment to a Point

5. Enter the information as shown, and then click Apply.

6. Display the northern end of the model as shown.
Note:You need to see the points on string 1001 and also both segments of string 16.

7. Choose Solids > Triangulate > Segment to a point.
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Creating a Solid Task: Create a Solid Using Segment to a Point

8. Enter the information as shown, and then click Apply.

9. Click a point of string 1001 (ie. the one you just digitised).
10. Click the matching segment of string 16.
11. Press ESC. You have now finished the first triangulation.
12. Choose Solids > Triangulate > Segment to a point.
13. Enter the information as shown, and then click Apply.

14. Click the second Northern point of string 1001.
15. Click the second matching segment of string 16.
16. Press ESC.

The northern end will look like the image shown.
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Creating a Solid Task: Create a Solid Using Segment to a Point

You will now repeat this process on the other end of the data.

17. Change to the view as shown.

18. Choose Solids > Triangulate > Segment to a point.
19. Enter the information as shown, and then click Apply.

20. Click the southern point of string 1001, and then click string 1.
21. Press ESC to finish the triangulation.

22. ick the icon to zoom to the data extents.
23. Choose Display > All layers.

Notice that there is still a gap between strings 15 and 16.  You will now create objects 9 and 10
to fill these gaps.

24. Choose Solids > Triangulate > Between segments.
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Creating a Solid Task: Create a Solid Using Segment to a Point

25. Enter the information as shown, and then click Apply.

26. Click a segment on string 15.
27. Click the corresponding segment on string 16.
28. Press ESC.
29. Choose Solids > Triangulate > Between segments.
30. Enter the information as shown, and then click Apply.

31. Click the other segment on string 15.
32. Click the corresponding segment on string 16.
33. Press ESC.

34. Save mod5.dtm.
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Creating a Solid Task: Create a Solid Using Segment to a Point

35. Click Yes.

Note:  If you want to see all of the steps performed in this chapter, run _04a_segment_to_a_
point.tcl.  You will need to click Apply on any forms presented.

If you want to run manually through the material again, you will need to copy original_mod5.dtm
tomod5.dtm.
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Creating a Solid Task: Triangulate a Fault – Data Preparation

Triangulating a Fault

Task: Triangulate a Fault – Data Preparation

1. Click the Reset graphics icon .
2. Open fault1.str.
3. Openmod6.dtm.
4. Choose Display > Hide surface/solid.
5. Choose Display > Strings > With string numbers.
6. Enter the information as shown, and then click Apply.

7. Rotate the data as shown to view the fault plane.
Section Strings plus fault are displayed.

The string fault1.str represents the fault through this area. Ideally, you need two
shapes that coincide with the fault on either side of the fault. The following steps illus-
trate one way of doing this.

8. Choose File > Save > string/DTM.
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Creating a Solid Task: Triangulate a Fault – Data Preparation

9. Enter the information as shown, and then click Apply.

10. Choose File > Save > string/DTM.
11. Enter the information as shown, and then click Apply.

12. Click the Reset graphics icon .
13. Open south1.str, north1.str and fault1.str.

The plan view of the fault is displayed.
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Creating a Solid Task: Triangulate a Fault – Data Preparation

You now need to press these strings onto the surface of the fault.

This function works only on Z or Description fields, therefore you will need to swap your Y and Z
coordinates to make this function work correctly (ie. go to section view).

1. Choose File tools > String maths.
2. Enter the information as shown, and then click Apply.

3. Choose File tools > String maths.
4. Enter the information as shown, and then click Apply.

5. Choose File tools > String maths.
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Creating a Solid Task: Triangulate a Fault – Data Preparation

6. Enter the information as shown, and then click Apply.

7. Click the Reset graphics icon .
8. Open n_section_view1.str, s_section_view1.str and f_section_view1.str in that order.

The fault with Ore Polygons is displayed.

9. Choose Surfaces > Create DTM from Layer.
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Creating a Solid Task: Triangulate a Fault - Draping Strings and Triangulating

10. Enter the information as shown, and then click Apply.

11. Save as f_section_view.dtm.

Note: To see all of the steps performed in this section, run _04b_triangulate_fault_data_prep-
aration.tcl. You will need to click Apply on any forms presented.

Task: Triangulate a Fault - Draping Strings and Triangulating

1. Choose Surfaces > DTM file functions > Drape strings over a DTM.
2. Enter the information as shown, and then click Apply.

The operation to be performed is Z = Z and this is the default operation displayed.
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Creating a Solid Task: Triangulate a Fault - Draping Strings and Triangulating

3. Enter the information as shown, and then click Apply.

Strings can also be pressed onto a DTM by opening the DTM into one layer and the string file
to be pressed into another. You will now press string 10 in file s1.str against the fault plane.

4. Click the Reset graphics icon .
5. Open f_section_view1.dtm.
6. Open s_section_view1.str, which contains string 10.
7. Rotate the view so you can clearly see the string.

8. Choose Surfaces > Drape string over DTM.
You are prompted to select the string to be draped over the DTM.

9. Click string 10.
You will be prompted to select the layer that contains the DTM file.

10. Enter the information as shown, and then click Apply.

Note: You will see that the string is pressed onto the DTM surface. New points will be inter-
polated into the pressed string so that the strings are pressed perfectly against the DTM sur-
face.

11. Save as s1.str.
12. Choose File tools > String maths, and swap n1.str (string 11) back to plan view as shown.
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Creating a Solid Task: Triangulate a Fault - Draping Strings and Triangulating

13. Choose File tools > String maths, and swap s1.str (string 10) back to plan view as shown.

Now you are ready to incorporate the newly created strings into your solid model.

14. Click the Reset graphics icon .
15. Open s1.str.
16. Open n1.str, appending it to the same layer.

Note: Hold down the CTRL key while dragging and dropping n1.str into graphics.

You should see that the two string segments are coincident along the plane of the fault.

17. Open and appendmod6.dtm.

Page 51 of 110



Creating a Solid Task: Triangulate a Fault - Draping Strings and Triangulating

Two string segments are displayed.

18. Choose Display > Hide everything.
19. Choose Display > Strings > With string numbers.
20. Enter the information as shown, and then click Apply.
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Creating a Solid Task: Triangulate a Fault - Draping Strings and Triangulating

21. Zoom in and adjust the view as necessary to see the data clearly.

22. Choose Solids > Triangulate > Between segments.
23. Enter the information as shown, and then click Apply.

24. Click string 10, segment 1 and then string 10, segment 2.
25. Press ESC.
26. Choose Solids > Triangulate> Between segments.
27. Enter the information as shown, and then click Apply.

28. Click string 11, segment 1 and string 11, segment 2.
29. Press ESC.
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Creating a Solid Task: Triangulate Inside a Segment

The following image is displayed.

30. Save asmod6.dtm.

If you want to run manually through the material again, you will need to copy original_mod6.dtm
tomod6.dtm.

Note: To see all of the steps performed in this section, run _04c_draping_strings_and_tri-
angulating_fault.tcl. You will need to click Apply on any forms presented.

Triangulating Using Inside Segment and One Triangle

Task: Triangulate Inside a Segment

1. Click the Reset graphics icon .
2. Openmod7.dtm.
3. Choose Display > Hide surface/solid.
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Creating a Solid Task: Triangulate Using the One Triangle Function

4. Choose Display > Strings > With string numbers.
5. Enter the information as shown, and then click Apply.

6. Choose Solids > Triangulate > Inside a segment.
7. Enter the information as shown, and then click Apply.

8. Click String 10, Segment 2. (ie. the segment located on the fault)
9. Choose Solids > Triangulate > Inside a segment.
10. Enter the information as shown, and then click Apply.

11. Click string 11, segment 2. (ie. the segment located on the fault)
12. Press ESC.
13. Save the result asmod7.dtm.

If you want to run manually through the material again, you will need to copy original_mod7.dtm
tomod7.dtm.

Note: To see all of the steps performed in this section, run _04d_triangulate_inside_seg-
ment.tcl. You will need to click Apply on any forms presented.

Task: Triangulate Using the One Triangle Function

1. Click the Reset graphics icon .
2. Openmod1.str.
3. Zoom in on any part of the file.
4. Choose Display > Point > Markers to display all the points in the segments.
5. Choose View > Data view options > View by bearing & dip.
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Creating a Solid Task: Triangulate Using Manual Triangulation

6. Enter the information as shown, and then click Apply.

7. Choose Solids > Triangulate > One Triangle.
8. Enter the information as shown, and then click Apply.

9. As prompted, click a point on a string.
10. As prompted, click a point on a following string.
11. As prompted, click a point on the first string, adjacent to the first point you selected.

Note: A closed triangle is displayed. The software prompts you to select another point. If
you select a point on the second string, a second triangle will appear. Using this process you
can manually build up the triangulation.

12. Press ESC.

Note: To see all of the steps performed in this section, run _04e_triangulate_one_triangle.tcl.
You will need to click Apply on any forms presented.

Triangulating Using Manual Triangulation

Task: Triangulate Using Manual Triangulation

1. Choose File > Open > String/DTM file.
2. Enter the information as shown, and then click Apply
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Creating a Solid Task: Triangulate Using Manual Triangulation

3. Choose View > Data view options > View by bearing & dip to change the view to Bearing =
70, Dip = -20.

4. Zoom in on strings 1 and 2.
5. Choose Display > Point > Numbers to display the numbering sequence of strings 1 and 2.
6. Choose Solids > Triangulate > By manually selecting points.
7. Enter the information as shown, and then click Apply.

Note: Follow the prompts at the bottom of the screen with care as the segments must be
selected in a strict order.

8. Click point 34 on string 1 and then the corresponding point 118 on string 2.
9. Click point 57 on string 1 and then the corresponding point 137 on string 2.
10. Press ESC.
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Creating a Solid Task: Triangulate Using Manual Triangulation

The triangulated image is displayed.

Note: To see all of the steps performed in this section, run _04f_triangulate_manual.tcl. You
will need to click Apply on any forms presented.
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Editing Solids Task: Edit a Solid

Editing Solids

Task: Edit a Solid

1. Click the Reset graphics icon .
2. Openmod8.dtm.
3. Choose Solids > Edit trisolation > Renumber.

Note: This function allows you to renumber a trisolation by pointing to and clicking on tri-
angles.

4. Click each trisolation in the lower part of the solid and enter the following information to
renumber all the trisolations south of the fault to Object = 1, Trisolation = 1.

5. Click each trisolation in the upper part of the solid and enter the following information to
renumber all the trisolations north of the fault to Object = 2, Trisolation = 1.

6. Press ESC.
You will see two objects displayed on the screen.

7. Save the file asmod8.dtm

If you want to run manually through the material again, you will need to copy original_mod8.dtm
tomod8.dtm.

Note: To see all of the steps performed in this section, run _06_edit_solid.tcl. You will need to
click Apply on any forms presented.
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Validating Solids Task: Validate Solids

Validating Solids

Task: Validate Solids

1. Click the Reset graphics icon .
2. Openmod10.dtm. This is the Solid model with objects 1 and 2.
3. Choose Solids > Validation > Validate object.
4. Enter the information as shown, and then click Apply.

Note: Leaving the object number blank will allow both object 1 and object 2 to be validated.

5. Open valid1.not.
The Solids Modelling Validation report is displayed.

6. Close valid1.not.
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Setting an Object to Solid or Void Task: Set an Object (Trisolation) to Solid or Void

Setting an Object to Solid or Void

Task: Set an Object (Trisolation) to Solid or Void

1. Click the Reset graphics icon .
2. Openmod11.dtm.
3. Choose Solids > Validation > Set object to solid or void.
4. Enter the information as shown, and then click Apply.

This will make both objects into solids.

5. Choose File > Save > string/DTM to save your model asmod11.dtm

Note: The solid can now be used to calculate a volume, or as a constraint in block model filling.
Later you will use the model you have created to demonstrate viewing solid models, intersecting
drill holes and performing volume calculations.

If you want to run manually through the material again, you will need to copy original_mod11.dtm
tomod11.dtm.

Note: To see all of the steps performed in this section, run _07_solids_validation.tcl. You will
need to click Apply on any forms presented.
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Triangulating Using Centre Line and Profile Task: Create a Solid Using Centre Line and Profile.

Triangulating Using Centre Line and Profile

Task: Create a Solid Using Centre Line and Profile.

1. Click the Reset graphics icon .
2. Open pfl1.str.

These are a series of profile strings representing the outlines of various underground fea-
tures.

3. Choose Display > Strings > With string numbers.
4. Enter the information as shown, and then click Apply.

The profiles examples are displayed.

5. Choose File > Save > string/DTM.
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Triangulating Using Centre Line and Profile Task: Create a Solid Using Centre Line and Profile.

6. Enter the information as shown, and then click Apply to save string 4 only into prof1.str.

7. Click the Reset graphics icon .
8. Open prof1.str.
9. Choose View > Zoom > Out.
10. Choose Display > 2D grid.
11. Enter the information as shown, and then click Apply.

Note: In order for the profile to be correctly applied to a centre line, the centre, bottom
point of the profile needs to have coordinates of X = 0, Y = 0.
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Triangulating Using Centre Line and Profile Task: Create a Solid Using Centre Line and Profile.

The profile example is displayed.

Note: The profile needs to move 10.75 in the x direction and -1 in the y direction to have its
bottom centre at (0,0)

12. Choose File tools > String Maths.
13. Enter the information as shown, and then click Apply.

14. Click the Reset graphics icon .
15. Open prof1.str.
16. Choose View > Zoom > Out.
17. Choose Display > 2D grid.
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Triangulating Using Centre Line and Profile Task: Create a Solid Using Centre Line and Profile.

18. Enter the information as shown, and then click Apply.

The profile is displayed.

Notice that the centre, bottom point of the profile is now at (0,0)

19. Click the Reset graphics icon .
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Triangulating Using Centre Line and Profile Task: Create a Solid Using Centre Line and Profile.

20. Open dcl100.str, which represents the centre line of a decline.

21. Choose Solids > Triangulate > Using centre line & profile.
22. Enter the information as shown, and then click Apply.

23. Click the centre line.
Note: The profile string is applied perpendicularly at each point in the centre line and then

these profiles are stitched together to form the object.

24. Choose Display > Hide everything.
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Triangulating Using Centre Line and Profile Task: Create a Solid Using Centre Line and Profile.

25. Choose Display > Strings As lines to see how the solid has been created.
26. Zoom in and use the orbit tool to make the solid easier to visualise.

The profiles on the centreline are displayed.

Notice that the solid is constructed by applying the profile to each point on the centre line

Note: The centre line and profile function does not save the new file automatically, so if you
want the file saved you should specify a new file name.

Note: To see all of the steps performed in this section, run _05_centre_line_and_profile.tcl.
You will need to click Apply on any forms presented.
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Intersecting Solids and DTM Surfaces Task: Perform Solids Union

Intersecting Solids and DTM Surfaces

Intersecting Solids

Task: Perform Solids Union

1. Click the Reset graphics icon .
2. Open decline1.dtm.
3. Open crosscut1.dtm.
4. Click the Zoom all icon .

Union of solids is displayed.

5. Choose Solids tools > Union solids.
6. Enter the information as shown, and then click Apply.

Note: The layer name cannot be the same as any existing layer. The new layer will contain
the new solid.

7. Follow the prompts by clicking each of the solids.
Note: The order of selection is not important. The program will go through the process of

uniting the two solids. Notice that the previous objects have been erased from screen and
you are now in the layer you specified with the unioned solid displayed. The solid is merely dis-
played in this layer. You must save it before exiting.

8. Choose View > Surface view options > Hide triangle edges and deselect this option for a
more effective display.

9. Zoom in to show the area of contact and confirm the result.
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Intersecting Solids and DTM Surfaces Task: Perform Solids Union

The union of the drives is displayed.

10. Choose View > Surface view options > Hide triangle faces to see that the underlying strings
have been changed as shown.
The union triangles are displayed.

Note: To see all of the steps performed in this section, run _08a_solids_union.tcl. You will need
to click Apply on any forms presented.
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Intersecting Solids and DTM Surfaces Task: Perform Intersection of Solids

Task: Perform Intersection of Solids

1. Click the Reset graphics icon .
2. Open lev1.dtm.
3. Open stope1.dtm.
4. Click the Zoom all icon .

These solids represent a stope and a development drive as shown.

5. Choose Solids > Solids tools > Intersect solids.
6. Enter the information as shown, and then click Apply.

7. Follow the prompts by clicking each of the solids in turn.
Note: The order of selection is not important.

8. You will now be in the layer you specified with the solid displayed. The result is that area of
the decline that fell within the stope.

Note: To see all of the steps performed in this section, run _08b_solids_intersection.tcl. You
will need to click Apply on any forms presented.

Task: Perform Outersection of Solids

1. Click the Reset graphics icon .
2. Open lev1.dtm.
3. Open stope1.dtm.
4. Click the Zoom all icon .
5. Choose Solids > Solids tools > Outersect solids.
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Intersecting Solids and DTM Surfaces Task: Perform Outersection of Solids

6. Enter the information as shown, and then click Apply.

7. Follow the prompts by clicking each of the solids - first the ore body and then the decline.

In this case, the order of selection is important. The outersected solid must be selected first, while
the outersecting solid (i.e. that one that will cut into the outersected solid) is selected second.

You will be in the layer you specified with the solid displayed. The result is the original solid body
with those areas that were common with the decline removed.

Note: To see all of the steps performed in this section, run _08c_solids_outersection_solid.tcl.
You will need to click Apply on any forms presented.
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Intersecting Solids and DTM Surfaces Task: Clip a Solid Above a DTM

Task: Clip a Solid Above a DTM

1. Click the Reset graphics icon .
2. Open pit4.dtm.
3. Open ore4.dtm.

The ore body is displayed.

4. Choose Solids > Solids tools > Clip solid above a DTM.
5. Enter the information as shown, and then click Apply.

6. Click the ore solid and then click the pit DTM.
The ore body is displayed.
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Intersecting Solids and DTM Surfaces Task: Clip a DTM Outside a Solid

7. Choose File > Save > string/DTM if you wish to save the results for further work.

Note: To see all of the steps performed in this section, run _08d_dtm_above_solid.tcl. You will
need to click Apply on any forms presented.

Task: Clip a DTM Outside a Solid

1. Click the Reset graphics icon .
2. Open pit4.dtm.
3. Open ore4.dtm.
4. Choose Solids > Solids tools > Clip DTM outside a solid.
5. Enter the information as shown, and then click Apply.

The output solid above the dtm will be stored in the layer dtm_outside_solid.

6. Click the solid, and then click the DTM.
The pit cut by the ore body is displayed.
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Intersecting Solids and DTM Surfaces Task: Perform Upper Triangles Intersection of 2 DTMs

7. Save dtm_outside_solid.dtm.

Note: This result is not a solid but is instead a DTM. Only that part of the pit surface that
occurred outside the solid ore body is retained.

Note: To see all of the steps performed in this section, run _08e_dtm_outside_solid.tcl. You
will need to click Apply on any forms presented.

Intersecting DTM Surfaces

Task: Perform Upper Triangles Intersection of 2 DTMs

1. Click the Reset graphics icon .
2. Open topo2.dtm.
3. Open dump1.dtm.

4. Choose Surfaces > Clip or intersect DTMs > Upper triangles of 2 DTMs.
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Intersecting Solids and DTM Surfaces Task: Perform Lower Triangles Intersection of 2 DTMs

5. Enter the information as shown, and then click Apply.

6. Follow the prompts by picking each of the DTMs.

Note: The order of selection is not important.

You will be in the layer you specified with the DTM displayed. The result is the waste stockpile sur-
face incorporated into the topographic surface.

Note: To see all of the steps performed in this section, run _08f_upper_triangles_of_2dtm.tcl.
You will need to click Apply on any forms presented.

Task: Perform Lower Triangles Intersection of 2 DTMs

1. Click the Reset graphics icon .
2. Open topo2.dtm.
3. Open pit2.dtm.
4. Choose Surfaces > Clip or intersect DTMs > Lower triangles of 2 DTMs.
5. Enter the information as shown, and then click Apply.

6. Follow the prompts by picking each of the DTMs.

Note: The order of selection is not important.
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Intersecting Solids and DTM Surfaces Task: Create a Solid by Intersecting 2 DTMs

The pit below the topography is displayed.

Note: To see all of the steps performed in this section, run _08g_lower_triangles_of_2dtm.tcl.
You will need to click Apply on any forms presented.

Task: Create a Solid by Intersecting 2 DTMs

1. Click the Reset graphics icon .
2. Open topo2.dtm.
3. Open pit2.dtm.
4. Choose Surfaces > Clip or intersect DTMs > Create solid by intersecting 2 DTMs.
5. Enter the information as shown, and then click Apply.

6. Follow the prompts by clicking each of the DTMs.
Note: The upper DTM (topography) must be selected first, followed by the lower DTM

(pit).
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Intersecting Solids and DTM Surfaces Task: Create a Solid by Intersecting 2 DTMs

You will be in the layer you specified with the solid displayed. The result is a solid representing
the material that will need to be removed from the designed pit.

7. Choose File > Save > string/DTM.
8. Enter the information as shown, and then click Apply.

9. Choose Solids > Solids tools > Report volume of solids to create a note file with the volume
of the pit below the topography.

10. Enter the information as shown, and then click Apply.
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Intersecting Solids and DTM Surfaces Task: Create a Solid by Intersecting 2 DTMs

The Solid Modelling object report is displayed.

Note: To see all of the steps performed in this section, run _08h_create_solid_intersecting_
2dtms.tcl. You will need to click Apply on any forms presented.
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Viewing Solids Task: View Solids

Viewing Solids

Task: View Solids

1. Click the Reset graphics icon .
2. Open pit1.dtm.

The pit example is displayed.

3. Choose Customise > Display properties > DTM’s and 3DM’s.

4. Change the colour of the faces for Object 1 and then click Apply.

Page 79 of 110



Viewing Solids Task: View Solids

5. Open fault1.dtm into its own layer.
6. Choose Customise > Display properties > DTMs and 3DMs.
7. Choose another colour for the faces for fault1.dtm (object 10).

The pt and fault line example is displayed.

Notice that the changes are reflected in the active layer only and the pit remains the same
colour.

8. Openmod12.dtm.
The solid with the pit and the fault is displayed.

9. Choose Display > Surface or solid with colour banding.
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Viewing Solids Task: View Solids

10. Enter the information as shown, and then click Apply.

The solid with sharp colour banding is displayed.
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Viewing Solids Task: View Solids

To display the solid with smooth contours.

11. Right-click on the file mod12.dtm.

12. Then tick Smooth shading.
The solid with smooth colour banding is displayed.

Note:To see all of the steps performed in this section, run _09_view_solid_model.tcl. You will
need to click Apply on any forms presented.
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Creating Sections Task: Create Sections Using the Interactive Method

Creating Sections

Task: Create Sections Using the Interactive Method

1. Click the Reset graphics icon .
2. Openmod12.dtm.
3. Choose Solids > Solids tools > Create sections.

4. Click the Digitise button to use your mouse for defining the axis.
5. Click a start point below the bottom centre of the ore body and drag the cursor vertically to

the end point of the axis line above the solid.
The solid with a centreline is displayed.
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Creating Sections Task: Create Sections Using the Interactive Method

Note: When you have created the axis, the form is redisplayed with the real world coor-
dinates of your axis line.  Adjust the coordinates manually using the digitised axis start and axis
end points as a guide.  In this case, the Eastings and elevations for the axis line must be the
same to produce slices that are oriented as Northings.

6. Enter the information as shown, and then click Apply.

7. Enter the information as shown, and then click Apply.

Note: Click the Interactive slider controls button to display your slices in real time.  The
slide controls enable you to adjust the start and end points of your axis and also the distance
between slices.  Try moving the slide controls up and down to see the effects of your
changes.  The slices are taken using the values in the boxes on the right side of the slider bars
when you click Apply.  Values may also be manually entered into these boxes.
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Creating Sections Task: Create Sections Using the Interactive Method

The solid object with slices is displayed.

8. Move the object about in 3D space to see how the slices relate to the solid.

Note: To see all of the steps performed in this section, run _10a_slice_objects_interactive.tcl.
You will need to click Apply on any forms presented.
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Creating Sections Task: Create Sections by Range

Task: Create Sections by Range

1. Click the Reset graphics icon .
2. Openmod12.dtm.
3. Choose Inquire > Report layer extents to determine the Maximum and Minimum Y, X and Z

coordinates.
Notice that the data shown in the window extends from 10055 north to 10920 north. By defin-
ing a north-south axis, the objects can be sliced.

4. Choose Solids > Solids tools > Create sections.
For this exercise you will be slicing this model on Northings (Y). To do this you will need to
define a vertical axis.

5. Enter the information as shown, and then click Apply.

6. Enter the information as shown, and then click Apply.
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Creating Sections Task: Create Sections Using a Centre Line

The solid with sections is displayed.

Note: To see all of the steps performed in this section, run _10b_slice_objects_by_range.tcl.
You will need to click Apply on any forms presented.

Task: Create Sections Using a Centre Line

1. Click the Reset graphics icon .
2. Open stope2.dtm.
3. Open cl2.str.

When slicing a solid, the centreline string and the objects to be sliced may be either in sep-
arate layers or in the same layer. For display purposes, it is generally simpler if separate layers
are used. Note that if they are in separate layers, the layer containing the solids to be sliced
must be set to the active layer.
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Creating Sections Task: Create Sections Using a Centre Line

4. Make stope2.dtm the active layer.

5. Choose Solids > Solids tools > Section using centre line.
6. As prompted, click the start and end points of your centre line.
7. Enter the information as shown, and then click Apply.
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Creating Sections Task: Create Sections Using a Centre Line

8. Enter the information as shown, and then click Apply.

9. Change the Layers Status to make the stope2.dtm layer invisible.

Ring slice is displayed.

Notice how the slices start at 90 degrees and the last slice is at 70 degrees.

Note: To see all of the steps performed in this section, run _10c_centre_line_slice.tcl. You will
need to click Apply on any forms presented.
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Reporting Volumes of Solids Task: Report Volume of a Solid

Reporting Volumes of Solids

Task: Report Volume of a Solid

1. Click the Reset graphics icon .
2. Openmod12.dtm.
3. Choose Solids > Solids tools > Report volume of solids.
4. Enter the information as shown, and then click Apply.

The file volume_report1.not is displayed.

5. Close the report file.

Note: To see all of the steps performed in this section, run _11_solids_volume_report.tcl. You
will need to click Apply on any forms presented.
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Intersecting Drill Holes with Solid Models Task: Intersect Drill Holes with Solid Models

Intersecting Drill Holes with Solid Models

Task: Intersect Drill Holes with Solid Models

1. Click the Reset graphics icon .
2. Openmod12.dtm.
3. Open solids.ddb.
4. Choose Database > Display > Drillholes.
5. Accept the default values, and then click Apply.

6. Accept the default values, and then click Apply.
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Intersecting Drill Holes with Solid Models Task: Intersect Drill Holes with Solid Models

The solid with drillholes is displayed.

The database has an optional table called Intersect, where you will store the results of this
processing.

7. Choose Database > Analysis > Drillhole 3DM intersection.
8. On the blank constraint form, click Apply.
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Intersecting Drill Holes with Solid Models Task: Intersect Drill Holes with Solid Models

9. Enter the information as shown, and then click Apply.

The table called Intersection within the database now contains a field called zone, in which a
character code south has now been stored.

The Drillhole Object Intersection report is displayed.

10. Close intersect.not.
11. Choose Database > Edit > View table constrained.
12. Enter the information as shown, and then click Apply.
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13. Enter the information as shown, and then click Apply.

14. Enter the information as shown, and then click Apply.

The intersections will be displayed.

15. Click Apply on the form.
Note: You can also view the results in the intersection table in the geological database.

16. Choose Database > Database > Close.
17. Turn Faces Off and rotate the data to see the intersections clearly.
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The drillhole trace is displayed.

Note: To see all of the steps performed in this section, run _12_intersect_drillholes_solids.tcl.
You will need to click Apply on any forms presented.
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Optimising Trisolations

Task: Optimise Trisolations

1. Click the Reset graphics icon .
2. Open filter1.dtm.
3. Choose Solids > Edit trisolation > Optimise.
4. Click anywhere on the object.
5. Enter the information as shown, and then click Apply.

6. Choose Display > Strings > As lines.
7. Enter the information as shown, and then click Apply
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8. Choose Solids > Edit trisolation > Delete redundant points.
9. Click Apply on the form presented.

Notice that more than 90% of the points were deleted and any segments not associated with a tri-
angle have been deleted.

Note: To see all of the steps performed in this section, run _13_optimise_trisolation.tcl. You
will need to click Apply on any forms presented.
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Modelling Underground Data

Task: Model Underground Data

1. Click the Reset graphics icon .
2. Open lev200.str.

Floor and back strings are displayed.

3. Choose Display > Strings > With string numbers.
4. Enter the information as shown, and then click Apply.

Note: In this case, the string numbers for the backs are 2 and 30003 and for the floor are 1
and 1001.  String 30003 is a spot height string.  You will need to create separate DTM files for
the backs and the floors.

5. Choose File > Save > string/DTM.
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6. Enter the information as shown, and then click Apply.

Note: This creates a string file containing just the back strings. Notice that the separator for
the string range is a semi colon. 

7. Choose File > Save > string/DTM.
8. Enter the information as shown, and then click Apply.

Note: This will create a string file containing just the floor strings. Notice that the separator
for the string range is a semi colon. 

9. Click the Reset graphics icon .
10. Open back1.str.

Strings 2 and 30003 are displayed.

11. Choose Inquire > Segment Properties and click on each segment to check its direction.
Notice that the pillar segment is anti-clockwise within an enclosing outer boundary segment
that is clockwise.

12. Choose Surfaces > Create a DTM from layer.
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13. Enter the information as shown, and then click Apply.

14. Choose Surfaces > Clip or intersect DTMs > Clip DTM with string.
You are prompted to select a string.

15. Click string 2 (ie. pillar and wall pickup string).
16. Enter the information as shown, and then click Apply.

The underground spot height string is displayed.

Note: The DTM has been clipped correctly due to the string directions set for the walls and
pillars.

17. Choose File > Save > string/DTM.
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18. Enter the information shown, and then click Apply.

19. Click the Reset graphics icon.
20. Open floor1.str.
21. Choose Surfaces > Create DTM from layer.
22. Enter the information as shown, and then click Apply.

23. Choose Surfaces > Clip or intersect DTMs > Clip DTM with string
You are prompted to select a string.

24. Click string 1.
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25. Enter the information as shown, and then click Apply.

The underground backs are displayed.

26. Save floor1.dtm.
27. Click Reset graphics .

Now that both clipped DTMs have been created, stitch together the sides to create a closed,
validated Solid model.

28. Open and append back1.dtm and floor1.dtm into the main graphics layer.
Note: To append the DTMs to the same layer, hold down the CTRL key and drag and drop

the files into graphics.

29. Choose Solids > Edit trisolation > Renumber.
30. Click back1.dtm.
31. Enter the information as shown, and then click Apply.
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32. Click floor1.dtm.
33. Enter the information as shown, and then click Apply.

Notice that the old trisolation number is 2 in this case.

34. Press ESC.
35. Save the file as drives1.dtm.

Note: When performing Solids modelling, it is good practice to save your work regularly.

36. Click Reset graphics .
37. Choose Display > Strings > With string numbers.
38. Enter the information as shown, and then click Apply.

39. Choose Solids > Triangulate > Between segments.
40. Enter the information as shown, and then click Apply.

41. Following the prompts from the function line, click first the outer back string, and then the
outer floor string

42. Press ESC.

Repeat the process for the pillar.

43. Choose Solids > Triangulate > Between segments.

Page 103 of 110



Modelling Underground Data Task: Model Underground Data

44. Enter the information as shown, and then click Apply.

45. Following the prompt from the function line, click first the top string of the pillar, and then the
bottom string of the pillar.

46. Press ESC.
The underground result is displayed.

47. Save drives1.dtm.
48. Choose Solids > Validation > Validate object.
49. Enter the information as shown, and then click Apply.
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The Solids Modelling validation report is displayed.

50. Choose Solids > Validation > Set object to solid or void.
51. Enter the information as shown, and then click Apply.

52. Choose Solids > Solids tools > Report volume of solids.
53. Enter the information as shown, and then click Apply.
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The Solid Modelling Object report is displayed.

Note: To see all of the steps performed in this section, run _15_create_underground_
model.tcl. You will need to click Apply on any forms presented.
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Using The Triangulation Algorithm

Task: Use the Triangulation Algorithm

1. Click the Reset graphics icon .
2. Open bifurc2.str.
3. Choose View > Data view options > View by bearing & dip.
4. Enter the information as shown, and then click Apply.

5. Choose Display > Strings > With string numbers.
The bifurcation example is displayed.

6. Choose Solids > Triangulate > Triangulation algorithm. 
7. Ensure that new algorithm with transforms is selected.

8. Choose Solids > Triangulate > Between segments.
9. Enter the information as shown, and then click Apply.
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10. Click string 1 then the right hand segment of string 2 as shown:

11. Press ESC.
12. Click the Reset graphics icon .
13. Open bifurc2.str.
14. Choose Solids > Triangulate > Triangulation algorithm.
15. Ensure that old algorithm with transforms is selected.

16. Choose Solids > Triangulate > Between segments.
17. Enter the information as shown, and then click Apply.

18. Click string 1 then the right most segment of string 2 as shown:

19. Press ESC.
Note: The old algorithm with transforms also achieved a successful result but took sig-

nificantly longer. This demonstrates the principal difference between the new and old algo-
rithms, ie. the new one is much faster.

20. Click the Reset graphics icon .
21. Open bifurc2.str and choose a similar view to that used before.
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22. Choose Solids > Triangulate > Triangulation algorithm.
23. Ensure that new algorithm is selected.

24. Choose Solids > Triangulate > Between segments.
25. Enter the information as shown, and then click Apply.

26. Click the same segments.
The bifurcation example is displayed.

In this case the segments are too far apart geometrically for either the old algorithms or new
algorithms (options 0 and 1 respectively) to work and the options with transforms should be
chosen in preference.

Finally, restore the triangulation algorithm to its original value.

27. Click the Reset graphics icon .
28. Choose Solids > Triangulate > Triangulation algorithm.
29. Enter the information as shown, and then click Apply.

Note: To see all of the steps performed in this section, run _16_triangulation_algorithm.tcl. You
will need to click Apply on any forms presented.
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References
For further information on this topic and related articles, log onto Gemcom's Knowledge Base at

www.gemcomsupport.com
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