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Surpac 6.3 

Solids 
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Intersecting Drill Holes with Solid Models 
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3 

Overview 
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4 

Solids Concepts 

Solid modelling allows us to use triangulation to create three-dimensional 
models based on Digital Terrain Models (DTMs) and String files. 

Solid models use triangles to link polygonal shapes together to define a solid 
object or a void. 

Solid models can be used for: 

Visualisation 

Volume calculations 

Extraction of slices in any orientation 

Intersection with data from the geological database module 

Solid model is created by forming a set of triangles from the points contained in 
the string.  

Triangles in a solid model may completely enclose a structure.  
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5 

Solids Concepts 

A solid model is made up of a set of non-overlapping triangles 

Triangles form objects that may have numerical identifier between 1 and 32000 

Objects represent discrete features in a solid model 

Object and trisolation numbers give reference to all the objects contained in 
solid model 

An object trisolation may be open or closed or can contain both trisolations 

Open: if there is a gap in the set of triangles that make up the trisolation 

The reasons for treating objects as open or closed: 

A closed object can have its volume determined directly by summing the volumes of each of the 
triangles to an arbitrary datum plane 

A closed object always produces closed strings when sliced by a plane 

A closed object could be used as a constraint in the block modelling module 
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Preparing a Data 

To ensure trouble free model creation, the integrity of strings should be checked 

prior to beginning modelling 

String direction: 

Strings should all be in the same direction, even if they are open strings 

Foldbacks (spikes): 

Foldbacks in a string will cause problems with  your model as they may cause overlapping triangles to be formed 

Excessive number of points: 

Large number of points will slow model creation and you should filter strings as necessary 

Duplicate points 

All data to be modelled needs to be in the same coordinate systems 

Use of normal plan projection will considerably simplify the modelling of the 

data 
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Preparing a Data 

Edit > Layer > Clean 
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8 

Assignment 1 – Preparing Data 

Prepare mod1.str for further processing 

Edit > Layer > Clean 
Check if the data is in right projection 

Check for spikes 

Check for duplicate points 

Save as mod1.str 

 

 

 

 

Set to 3D space or Surpac will delete all 

 points trying to flatten the model 

 Where applicable, set minimum trap 

 distance to 0.05, otherwise Surpac 

 will remove too many points. 
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Creating a Solid 

Various triangulation methods can be used to create a solid model 

Using between segments 

Using control strings 

Using bifurcation techniques 

Using manual triangulation 

Using many segments 

Using segment to a point 

Using inside segment and one triangle 

 

 

 

 

 

Also available in the solids toolbar (profile) 
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10 

Why we use different triangulation types... 
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11 

Triangulating using Between the Segments 

Triangulation between segments is the most commonly used of the solid 

creation techniques 

It uses algorithms that minimise the surface area of triangles formed between 

polygons 

It is simple to use and for many objects produces the best results 
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12 

Assignment 2 – Triangulating between segments 

Open mod1.str 

Display string numbers 

Triangulate between segments 1-2-3-4-5 

Press Esc 

Save as Mod1.dtm  
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13 

Triangulating using Control Strings 

Control strings are strings created to control the triangulation process – WHY? 

These strings link together points on your object polygons that have a strong 

structural relationship 

Rules: 

2-10 control strings 

The first control string (master) must link all the segments to be triangulated 

Subsequent control string may link some or all of the segments and may not have more points 

than master control string 

Control strings must be all in the same direction 

Control strings must not cross 

Do not use same string numbers as the polygons you are modelling 

Strings should make sense structurally 
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14 

Assignment 3 – Triangulating, Control Strings 

 Open mod2.str 

Solids > Triangulate > Using control strings 

Click on each control string 

Esc 

Enter the information below: 

 

 

 

 

 

Save as Mod1_control_string.dtm 
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15 

Triangulation using Many Segments 

Useful if the data is not numerically sequenced  

It is possible to select segments in the order you want triangulation to occur 

Rules: 

Organize data in numerical sequence if selecting strings or segments by a range 

Only display what needs to be displayed if selecting segments manually i.e. erase objects that 

might obscure the string data 

 

 



3D
S

.C
O

M
/G

E
O

V
IA

©
 D

as
sa

ul
t S

ys
tè

m
es

 | 
C

on
fid

en
tia

l I
nf

or
m

at
io

n 
| 1

0/
29

/2
01

2
 | 

re
f.:

 3
D

S
_D

oc
um

en
t_

20
12

 

16 

Assignment 4 – Triangulation, Many Segments 
Open mod3.str (display strings 11 – 14) 

Select Solids > triangulate > Many segments 
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17 

Triangulating using Bifurcation Techniques 

One segment to many segments 

For triangulation between one closed parent segment and many children 

 

 

 

 

 

 

One segment to two segments (bifurcation union) 

Function allows you to triangulate between one closed parent and two children.  

Can give more flexibility in where the bifurcation actually occurs 

It has the potential to be more geologically correct 

Option to join all of the parent segment to all of the child segments, or to split the parent segment up 
and join a portion of it up with each segment 
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18 

Assignment 5 – Bifurcation Techniques 

A. Create bifurcation on strings: 
Open Bifurc1.str 

Display point markers 

Select bifurcation one to many 

Follow instructions 

Save as one_to_many.dtm 

 

 

B. Now use one to two segments 
Open Bifurc1.str 

Select bifurcation one to two 

Follow instructions 

Save as one_to_two.dtm 

Notice the difference? 
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19 

Triangulating using Manual Triangulation 

Gives high level of control, while still leaving a degree of automation to the 

triangulation process 

You are able to create solid of extremely complex geometry that will exactly 

match geometrical interpretation of the data 

You control start and end points of the triangulation on a segment-by-segment 

basis 

Same direction of strings rule must apply 

 



3D
S

.C
O

M
/G

E
O

V
IA

©
 D

as
sa

ul
t S

ys
tè

m
es

 | 
C

on
fid

en
tia

l I
nf

or
m

at
io

n 
| 1

0/
29

/2
01

2
 | 

re
f.:

 3
D

S
_D

oc
um

en
t_

20
12

 

20 

Triangulating using Segment to a Point 

This function allows you to automatically triangulate from a selected segment to 

a selected point 

Another technique which can be used to close the ends of an open DTM 

Closed DTMs are significant because the volume report can be generated from them 

The triangulate to a point function can be used to accurately model ‘pinch outs’ 

in geological lenses 
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21 

Triangulating using String Morphing 

This function creates new segments equally spaced between two existing 

segments which are selected in graphics. 

String morphing can greatly improve the nature of solid models by ensuring a 

smoother transition between structures on adjacent segments, and can greatly 

reduce the staircasing effect when solid modelling.  

Morphing additional intervening segments often enables the solid modelling of 

otherwise difficult segments. 
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22 

Assignment 6 – String Morphing 

Open mod1.str 

Display string numbers 

Select: Solids > Triangulate > String Morphing 

 

 

 

 

 

 

 

 

Select: Solids > Triangulate > Many segments 

Select Manual in the following form 

Save as morph_mod1.dtm 
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23 

Triangulating Using Centre Line & Profile  

This function allows you to create a DTM of a given profile along a specified 

string 

The centre line is chosen by selecting a string in the graphics window with the 

mouse and the profile is taken from the string file 

This profile is placed at each point on the centre line string and rotated to be 

perpendicular to the centre line string 

Finally the strings are stitched together to create a solid 

The ends of this DTM may be optionally closed or left open 

 

In order for the profile to be correctly applied to a centre line, the centre bottom 

point of the profile needs to have coordinates of X=0 and Y=0 
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24 

Assignment – Centre Line & Profile  

Open Dcl100.str 

Select Solids > Triangulate > Using centre line and profile 
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25 

If you see twisting of the DTM... 

If the model looks like this, there are not enough points along the string. 

To add more points: 

Edit>segment>normalise segment 

Fill in a below and apply 



3D
S

.C
O

M
/G

E
O

V
IA

©
 D

as
sa

ul
t S

ys
tè

m
es

 | 
C

on
fid

en
tia

l I
nf

or
m

at
io

n 
| 1

0/
29

/2
01

2
 | 

re
f.:

 3
D

S
_D

oc
um

en
t_

20
12

 

26 

Editing Solids 

Functions for making permanent changes to the objects, trisolations and 

triangles 

Edit object: applies to object and all trisolations of the selected object 

Edit trisolation: applies to trisolations and all triangles on the selected trisolation 

Edit triangle: applies to individual triangles 
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27 

Assignment 7 – Editing Solids 

Assignment: 

Change the solid number 2 to solid number 1 in file mod8.dtm 
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28 

Validating Solids 

To check that the model has been correctly formed 

Only correctly formed models are used for volume calculations, block model 

constraints, intersecting drillholes... 

Different validation techniques 
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Validating Solids 

Creates topology index for a DTM and validates it 

Topology index = each triangle contains information about three triangles which are its neighbours 

Trisolation is evaluated as being open or closed 

Validation consists of looking for: 

Duplicate triangles 

Invalid trisolation edges 

Self intersecting triangles 

Open sides triangles 

If all above mentioned are found, these are highlighted on the screen in a user 

chosen colour and the trisolation is validated as false 

Set object (trisolation) to solid or void 

To ensure that all the triangles in all trisolations of a DTM are consistent in direction  
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Validating Solids 
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Solids Fixing 
Fixing solids in Surpac is automated. 
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Solids Fixing 

In solids > validation > solids repair. 

A new toolbar will be displayed. 

The problem triangles are highlighted and categorised. 

These can be deleted, redrawn, split, etc. 

 

In the folder Invalid_DTMS there are several solids to test. 

Can you fix all of these solids? 



3D
S

.C
O

M
/G

E
O

V
IA

©
 D

as
sa

ul
t S

ys
tè

m
es

 | 
C

on
fid

en
tia

l I
nf

or
m

at
io

n 
| 1

0/
29

/2
01

2
 | 

re
f.:

 3
D

S
_D

oc
um

en
t_

20
12

 

33 

Reporting Volumes of Solids 

Used to generate .not file indicating the status, surface area and volume for 

each trisolation of an object. 

Function calculates the volume of a closed object or trisolation 

In order to generate a volume, the solid must be validated and also have its 

direction set 
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Intersecting Solids and DTM Surfaces 

With intersections of solids you can create: 

Union solids 

Intersect solids 

Outersect solids 

Clip solid above DTM 

Clip DTM outside a solid 
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Intersecting Solids and DTM Surfaces 

Solids Union: 

This function allows you to merge two solids together 

Solid Tools > Union Solids 

The order of selection is not important 

 

 

 

 

 

 

 

 

 

(decline1.dtm and crosscut1.dtm) 
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Assignment 8 – Intersecting Solids 

Open decline1.dtm and crosscut1.dtm 

Type ZA 

Select: Solids > Solid Tools > Union Solids 
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Intersecting Solids and DTM Surfaces 

Solids Intersection: 

Function allows you to intersect two solids and creates a new solid, which represents the volume 

common to both 

Solid Tools > Intersect Solids 

Order of selection is not important 

 

 

 

 

 

 

 

 

(lev1.dtm and stope1.dtm) 
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Intersecting Solids and DTM Surfaces 

Outersection of Solids: 

Function allows you to find the difference between two solids 

The order of selection is important: 

First to select is the solid to be outersected 

Second to select is the outersecting solid 

Solid Tools > Outersect Solids 
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Intersecting Solids and DTM Surfaces 

Clipping a Solid Above a DTM: 
Function allows you to find the portion of a solid that is above DTM 

Creating a solid that represents the volume of an ore body above the DTM 

Solid Tools > Clip Solid Above a DTM 

 

 

 

 

 

 

 

 

 

 

(pit4.dtm and ore4.dtm) 
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Intersecting Solids and DTM Surfaces 

Clipping a DTM Outside a Solid: 
Function will retain part of the DTM that occurred outside the solid 

Solid Tools > Clip a DTM Outside a Solid 

 

 

 

 

 

 

 

 

 

 

 

(pit4.dtm and ore4.dtm) 
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Creating Sections 
Three different methods used to create sections from solids: 

Creating sections using the interactive method 

Creating sections by range 

Creating sections using a centre line 

Creating sections using the interactive method: 
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Creating Sections 

Creating sections using the interactive method: 

Function allows you to extract horizontal, vertical or inclined slices through an object 

The plane of intersection of the slices is defined by entering the Y,X,Z coordinates at each end of 

a 3D axis line and by specifying the interval along that axis at which slices are to be taken 

Two results are produced: 

Range of a string files which contain the extracted sections in section coordinates (saved to disk) 

File which contains the extracted sections in real world coordinates  displayed on the screen in different layer 

Reason to slice a DTM is to show one section at a time through a geological model along with 

the drill holes for that section posted to it 
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Creating Sections 

Creating sections using the interactive method: 
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Creating Sections 

 Creating sections by range: 
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Creating Sections 

 Creating sections by range: 
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Creating Sections 

Creating sections using a centre line: 

This function allows you to extract slices through a DTM and/or a block model in the current 

graphics layer along a segment (centre line) 

The centre line along which the slices are taken is defined by selecting two points on a segment 

Slices are taken along the segment at a specified spacing and at a specified dip 
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Assignment 9 – Sections using centre line 

Open cl2.str 

Open stope2.dtm 

Select: Solids > Solids tools > Section using centreline 

 

 

 

 

 

 

 

Turn edges off to view the sections 
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Intersecting Drill Holes with Solid Models 

This function allows you to perform intersection between drill holes stored in a 

drill hole database and 3D objects and then store the intersection data in a 

database  

 



3D
S

.C
O

M
/G

E
O

V
IA

©
 D

as
sa

ul
t S

ys
tè

m
es

 | 
C

on
fid

en
tia

l I
nf

or
m

at
io

n 
| 1

0/
29

/2
01

2
 | 

re
f.:

 3
D

S
_D

oc
um

en
t_

20
12

 

49 

Assignment 10 - Drill Holes/Solid Intersection  

Open mod12.dtm and connect to solids.ddb 

Display drillholes, accept defaults 

Select Database > Analysis > Drillhole 3DM intersection 
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Assignment 10 - Continued 

Select: Database > Edit > View table constrained 

 

 

 

 

 

 

 

 

Close the database  

Turn transparency to 40% 
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End of Day 3 

Any Questions? 

 

 

 

 

 

 

 


